Pomme Happy

Plus de pommes = moins de pépins !

Accueil » Podcast » Les tests conditionnels logiques SI ET OU

Les tests conditionnels, ou plutôt tests logiques, servent à vérifier si une valeur ou une cellule correspond à certains critères et, en fonction du résultat, à renvoyer une valeur (textuelle ou en chiffre) ou d’effectuer une opération ou une action.

La syntaxe de la fonction SI est la suivante :

=SI(condition; réponse ou action si VRAI ; réponse ou action si FAUX)

Celle de la fonction ET :

=ET(condition1;condition2

le nombre de conditions peut être plus important il suffit de les séparer par un point virgule
Le ET renverra la valeur VRAI si toutes les conditions entre parenthèses sont respectées

Celle de la fonction OU :

=OU(condition1;condition2)

Même construction que pour le ET.
Le OU renverra la valeur VRAI si l’une des conditions entre parenthèses est respectée.

Ces formules qui paraissent relativement simples de prime abord peuvent vite devenir très complexes mais surtout d’une redoutable efficacité.

Voici la liste des opérateurs :

opérateurs

Quelques Exemples :

=SI(A1="Coucou";"OK";"")

Si la cellule A1 contient le texte Coucou, alors on écrit OK dans la cellule active. Sinon on laisse cette cellule vide.

=SI(GAUCHE(A2;2)="33";"Gironde";RECHERCHEV(GAUCHE(A2;2);A10:B20;2;FAUX))

Si les deux premiers caractères de la cellule A2 renvoient la valeur 33, alors on écrit le mot Gironde, sinon on recherche verticalement dans la matrice A10:B10 la valeur de la deuxième colonne correspondant à la valeur exacte (si elle existe, sinon on obtiendra un #N/A) renvoyée par la formule GAUCHE(A2;2).

On peut ainsi incorporer des formules pour les conditions mais également pour les actions à effectuer.

On peut imbriquer autant de SI que l’on veut pour tester toutes les valeurs possibles pour autant que le résultat soit logique.

Vous trouverez dans la vidéo ci-dessous quelques exemples d’utilisation de ces tests logiques.

N’hésitez pas à faire à laisser des commentaires ou à poser des questions.
pommehappy.fr

@ bientôt !

_

Play


quatre × = 8

Mode Streetwear Homme
  • RSS
  • Facebook
  • Twitter
  • Delicious
  • Youtube
  • Vimeo
  • Google+
  • iTunes

Articles populaires

une hosts Editer le fichier hosts sous Mac OS X

Le fichier hosts est un fichier utilisé par le système d'exploitation ...

osX-mountain-lion Applications compatibles avec Mac OS X Moutain Lion

Si vous avez l'intention de passer ...

apps lion Applications compatibles avec Mac OS X Lion

A l'heure ou j'écris, il est ...

SnowLeopard Kit de Démarrage pour Mac OS X – 1/3

MAJ le 24/03/2012 Il faut bien un ...

mac_os_x_lion_dvd Graver Mac OS X Lion sur DVD ou sur une clé USB

Cela ne vous aura sans doute ...