Pomme Happy

Plus de pommes = moins de pépins !

Accueil » Bureautique » Déterminer si une année est bissextile dans un tableur

Comment déterminer si une année est bissextile ou non ?

Il se peut que, pour différent calculs et plus particulièrement cette année, que vous deviez déterminer si le nombre de jours est de 365 ou de 366.

Comme vous le savez sûrement, le véritable cycle de rotation de la terre autour du soleil n’est pas de 365 jours mais de 365 jours 1/4 (365.25635 précisément).

Aussi toutes les 4 années, un jour supplémentaire est ajouté au calendrier.

Ceci dit, l’arrondi fait que le calcul serait chroniquement inexact.

Pour corriger ce phénomène, une convention a été mise au point par les grégoriens : il faut que l’année (numérique) soit divisible par 400 (donc que son reste soit également à 0) mais également qu’elle soit divisible par 4 mais pas par 100.

Ainsi l’année 1900 par exemple qui devrait être bissextile ne l’est pas.

Ceci se traduit dans EXCEL ou OOo Calc par la formule suivante (si l’année testée se trouve dans la cellule A1) :

=SI(OU(MOD(A1;400)=0;ET(MOD(A1;4)=0;MOD(A1;100)<>0))=VRAI; »Bissextile »; »Normale »)

MOD est une fonction qui retourne le reste d’une division.

 


Documentation :

On trouve une vilaine traduction automatique sur les pages du support Microsoft

Pour en savoir plus à propos d’une année Bissextile sur Wikipédia

Source :

 Cette astuce est issue de la FAQ Business Object sur Developpez.com et transcrite par mes soins en Excel 😉

Support :

Fichier Open Office  Bissextile.ods

Fichier Excel  Bissextile.xlsx


Sécurité * Le temps imparti est dépassé. Merci de saisir de nouveau le CAPTCHA.

  • RSS
  • Facebook
  • Twitter
  • Delicious
  • Youtube
  • Vimeo
  • Google+
  • iTunes

Articles populaires

Editer le fichier hosts sous Mac OS X

Le fichier hosts est un fichier utilisé par le système d'exploitation ...

Applications compatibles avec Mac OS X Moutain Lion

Si vous avez l'intention de passer ...

Applications compatibles avec Mac OS X Lion

A l'heure ou j'écris, il est ...

Comment créer une clé USB bootable sous Mac OS X

Vous aurez peut être besoin de ...

Kit de Démarrage pour Mac OS X – 1/3

MAJ le 24/03/2012 Il faut bien un ...